Home / آموزش / آموزش شبکه / چگونه روتر خود را یک DHCP server کنیم

چگونه روتر خود را یک DHCP server کنیم

آموزش راه اندازی DHCP Server برروی router های سیسکو

سیستم عامل IOS سیسکو قابلیت این را دارد تا به عنوان یک DHCP سرور عمل کند و از یک IP Address Pool اقدام به اختصاص آدرس IP به ملاینت ها نماید. همچنین میتوانید اینترفیس های روتر خود را به گونه ای تنظیم کنید که IP خود را از DHCP server دریافت کنند.

در ادامه به اعمال تنظیمات فوق بر روی یک روتر سیسکو میکنیم. نمونه انجام شده برروی روتر سری ۲۶۰۰ سیسکو میباشد.

یک سناریوی ساده:

آدرس نتورک (Network Address): برای مثال ۱۷۲٫۲۰٫۱٫۰/۲۴ که ۲۴/ برابر با ۲۵۵٫۲۵۵٫۲۵۵٫۰ خواهد بود. یعنی رنج آدرس های IP قابل استفاده ما از ۱۷۲٫۲۰٫۱٫۱ تا ۱۷۲٫۲۰٫۱٫۲۵۴ است.

آدرس IP سرور DHCP: در این مثال ۱۷۲٫۲۰٫۱٫۱ که در واقع آدرس IP روتر ما خواهد بود.

و برای مثال تعداد ۱۰ آدرس IP را به اصطلاح exclude میکنیم تا به کلاینت ها اختصاص داده نشوند. از ۱۷۲٫۲۰٫۱٫۱ تا ۱۷۲٫۲۰٫۱٫۹ را برای این منظور استفاده میکنیم.

Exclude کردن IP ها زمانی به درد میخورد که میخواهیم از همان رنج تعداد IP برای سرور ها یا هر چیز دیگری رزرو کنیم و به صورت دستی آنها را تنظیم کنیم.(کاملا به نوع نیاز شما و سلیقتون برمیگرده.

مرحله پیاده سازی:

دستورات با رنگ قرمز و متغیر ها (با توجه به نوع دستگاه یا متغیر های انتخابی شما) با رنگ آبی مشخص شده اند!

۱- ابتدا به اینترفیسی که میخواهیم یک IP اختصاص میدهیم:

R1# configure terminal
R1(config)# interface fastethernet0/0
R1(config-if)# ip address 172.20.1.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit

حتما از دستور no shut بعد از انجام تنظیمات استفاده کنید.مخصوصا در روتر (به صورت پیشفرض پورت ها در روتر shutdown هستند).

۲- تنظیمات DHCP را انجام میدهیم:

R1(config)# ip dhcp excluded-address 172.20.1.1 172.20.1.9
R1(config)# ip dhcp pool MY_POOL
R1(dhcp-config)# network 172.10.1.0 255.255.255.0
R1(dhcp-config)# default-router 172.10.1.1
R1(dhcp-config)# dns-server 172.10.1.1
R1(dhcp-config)# domain-name opentechguides.com
R1(dhcp-config)# exit

دستور ip dhcp excluded-address رنج آی پی هایی که میخواهید از رنج اصلی رزرو شود مشخص میکند.

دستور ip dhcp pool برای نام گذاری رنج IP های که میخواهید استفاده میشود.

با دستور network مشخص میکنید چه رنج IP با چه subnet mask ای میخواهید استفاده شود.

دستور default-router در واقه آدرس آی پی Gateway شما است. اگر همان روتری که به عنوان DHCP server کار میکند Gateway شما برای آن رنج از شبکه است آدرس همان روتر را بعد از این دستور قرار میدهیم.

به همین سادگی میتوانید از روتر خود به عنوان DHCP Server استفاده کنید.

برای اینکه یکی از اینترفیس های Router تون رو به صورت DHCP Client تنظیم کنید به صورت زیر عمل کنید:

RouterA# configure terminal
RouterA# interface fastethernet0/0
RouterA# ip address dhcp
RouterA# no shutdown

منبع: opentechguides.com

 

دانلود IOS های سوئیچ های سری ۳۷۵۰ از اینجا

دانلود IOS های سوئیچ های سری ۳۵۶۰ از اینجا

دانلود IOS های سوئیچ ها سری ۲۹۶۰ از اینجا

 

این مقاله برای شما مفید بود؟ لطفا نظر خود را بنویسید.

پاسخ سوالاتون رو پیدا نکردید؟ در نظرات آن را مطرح کنید.

 

 

فروش ویژه سرور های دست دوم HP

سرور کارکرده HP DL380 G7

سرو HP dl380

سرور کارکرده HP ML350 G6

سرور HP مناسب

فروش ویژه محصولات دست دوم سیسکو

Cisco 3750 POE فروش
سوییچ سیسکو ۳۷۵۰ G  بیست و چهار پورت POE گیگ
Cisco 3750 POE فروش
سوییچ سیسکو ۳۷۵۰ چهل و هشت پورت POE

درباره محمد کلینی

از سال 1382 به صورت تخصصی وارد دنیای شبکه شدم، از MCP مایکروسافت شروع کردم تا Microsoft MCSE 2003 و بعد ها 2008 و همینطور MCTS در 3 گرایش،تا اینکه وارد شرکت نفت شدم و وارد مبحث مجازی سازی با استفاده از پلتفرم VMWare شدم، و بعدها به صورت تخصصی سیسکو و تکنولوژی های مرتبط با آن را کار کردم تا به امروز! عاشق طبیعت و طبیعت گردی و مسافرت هستم و از هر فرصتی برای رفتن به دل طبیعت استفاده میکنم! و رویای جهانگردی رو همیشه تو سر داشتم و الانم بیشتر از همیشه دوست دارم تا دنیا رو ببینم!!

Check Also

آموزش استفاده از poe

سیسکو inline power, POE یا POE پلاس

سیسکو Inline power، POE یا POE پلاس. کدام یک برای شما مناسب هستند؟ دو تکنولوژی ...

نظر بدید!

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

عضویت در خبرنامه
برای دریافت آموزش های کاربردی در زمینه شبکه و کامپیوتر، اطلاعات زیر را تکمیل کنید! ما هیچ وقت به ایمیل شما اسپم نمیفرستیم و آن را در اختیار دیگران قرار نخواهیم داد.
میخواهید کوپن های تخفیف برایتان ارسال شود؟
فقط کافیست نام و ایمیل خود را وارد کنید! تخفیف های شگفت انگیز برایتان ارسال میشود!!
ما هیچ وقت برای شما اسپم نمیفرستیم!!!
میخواهید کوپن های تخفیف برایتان ارسال شود؟
فقط کافیست نام و ایمیل خود را وارد کنید! تخفیف های شگفت انگیز برایتان ارسال میشود!!
ما هیچ وقت برای شما اسپم نمیفرستیم!!!
عضویت در خبرنامه
برای دریافت آموزش های کاربردی در زمینه شبکه و کامپیوتر، اطلاعات زیر را تکمیل کنید! ما هیچ وقت به ایمیل شما اسپم نمیفرستیم و آن را در اختیار دیگران قرار نخواهیم داد.